yaml.load()警告:YAMLLoadWarning: calling yaml.load() without Loader=…

YAML 5.1版本后弃用了yaml.load(file)这个用法,因为觉得很不安全,5.1版本之后就修改了需要指定Loader,通过默认加载器(FullLoader)禁止执行任意函数,该load函数也变得更加安全。

函数修改为:
yaml.load(input, Loader=yaml.FullLoader)

0

Leave a Reply

Your email address will not be published.