Linux如何编译gpu版本的darknet

darknet是一个用纯c语言开发的基于cudnn的深度学习框架,有python的接口,在目标检测领域具有非常重要的影响力,支持cpu和gpu,cpu版本就不多说了,下面介绍如何编译gpu版本的darknet 1、下载源代码 官网githup地址:https://github.com/pjreddie/darknet # 用git命令下载 git clone https://github.com/pjreddie/darknet.git 因为githup在国外,如果觉得下载有点慢,我本地已经提前下载,下载地址:darknet-master.zip # 用wget命令下载 wget -c -t 20 https://www.ivdone.top/wordpress/pic/p1710/darknet-master.zip 2、编译安装gpu版本darknet 先设置环境变量,查看你的cuda安装目录,比如我的安装目录如下: /usr/local/cuda darknet需要nvcc的命令,需要导出环境变量

Read More

CentOS 8 / RHEL 8 源码编译安装Tesseract-OCR 4.0及以上

Tesseract是一个非常著名的OCR开源项目,现在由google在维护,支持上百种语言,现在还在不断的更新中,版本已经到了4.1及以上,这个版本使用的神经网络模型训练的,使用的LSTM网络结构,但是在教程上官方只介绍Ubuntu的使用安装方法,然而在我的CentOS 8 / RHEL 8安装上出现了很多问题,最后我安装成功,现在总结一下安装的全过程,分享给大家,希望大家在评论区给出意见。 1、安装依赖环境 安装相关的依赖环境的库 yum install gcc-c++ yum install zlib-devel yum install pkg-config yum install libtool automake

Read More

Centos源码安装ICU 52.2的libicu-devel 库

我们在安装Tesseract-4.1 OCR训练工具时,需要用到libicu-devel库,但是版本至少是52.1的,下面介绍如何在Centos下安装52.2版本的ICU 1、安装报出警告 我们在源码安装Tesseract-4.1时,用下面的命令配置 ./configure –with-extra-includes=/usr/local/include –with-extra-libraries=/usr/local/include 会出现下面的警告,虽然是警告,不影响你使用,但是没有这样的库,你是无法对这个模型进行训练的 configure: WARNING: icu 52.1 or higher is required, but was not found.

Read More

centos7安装libicu-dev,libpango1.0-dev,libcairo2-dev

我们在使用Tesseract项目的时候,在训练自己的数据的时候需要用到这三个库,但是官方只给出了Ubuntu的教程,下面介绍在centos7中怎么安装这些库 1、Ubuntu安装 在Ubuntu中使用下面的命令安装 sudo apt-get install libicu-dev sudo apt-get install libpango1.0-dev sudo apt-get install libcairo2-dev 2、centos安装 在Centos中使用下面的命令安装 yum install libicu-devel

Read More